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Adding subject headings to vendors' record
sets with MarcEdit

NNELS implements LCSH and FAST subject headings. This page provides instructions on how to add
these subject headings to vendors' records before importing to Drupal.

Although some vendors' record sets may have LCSH or FAST subject headings present, it is more
efficient to carry out the following process to maximize the number of subject headings in our records.

Download the latest version of MarcEdit if you don't have it already.

A. Batch search OCLC with ISBNs

=

. Open the vendors' xml file in MarcEdit > MarcEditor.

. Save the xml file as mrk by adding the .mrk extension.

. Close the file and reopen it. (I have encountered quite often that edits don't get saved if | work
directly with the renamed file. Closing and reopening seems to solve the problem.)

4. Open MarcEdit > Tool > Export Tab Delimited Records.

5. For MARC File use the converted vendors' mrk file, name the new txt file.

6. Choose Tab (t\) as Delimiter.

7. Add field 020 and subfield $a (or the corresponding field with ISBNs).

8. Check Normalize Data and click Process.

N MARC Utilities

Batch Process Character Conversions MARCJoin  MARCSplit

w N

MARC File:  NNELS/2019-2020/subject_headings/test/test03/Blackstone.m _|
N

Save File; NNELS/2019-2020/subject_headings/test/test03/Blackstone.tx |

Batch Process

Delimiter: In Field Delimiter: Contextual Delimiter
Tab (\t)

020%a

o Mormalize Data

Field: Subfield: [+ X

Settings... Process Close

9. Open the new txt file in Excel.
10. Remove the first row, i.e., 020%a.
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11. Use Text to Columns to separate the repeated fields if present.

1. highlight the first column
2. go to Data > Text to Columns

CE o E :F;"

Be

Consolidate

3. in the pop-up wizard, choose Delimited, follow the prompts, choose Semicolon, and then

Finish o - - o
Convert Text to Columns Wizard - Step 10f 3

The Text Wizard has determined that your data is Delimited.

If this is correct, choose Next, or choose the Data Type that best describes your data.

) Delimited - Characters such as commas or tabs separate each field.

Fixed width - Fields are aligned in columns with spaces between each field.

Preview of selected data:
Preview of selected data:

H: 932‘51153?; 1987611634 . 97E198261 1644 ; 196761 1642
3 B781982681168 ; 1982681183, 9761982601195 ; 1982681191

Cancel

Finish

4. make sure the ISBNs are shown correctly. If not, fix the cell format:
1. go to Home tab, choose More Number Formats...

https://wiki.libraries.coop/

Printed on 2024/06/03 07:44


https://wiki.libraries.coop/lib/exe/detail.php?id=public%3Annels%3Acataloguing%3Aadd-subject-headings&media=public:nnels:cataloguing:excel_texttocolumns.png
https://wiki.libraries.coop/lib/exe/detail.php?id=public%3Annels%3Acataloguing%3Aadd-subject-headings&media=public:nnels:excel_texttocolumnswizard.png

2024/06/03 07:44 3/10 Adding subject headings to vendors' record sets with MarcEdit

AutoSave @ fidHh-U 3 I Blackstone_retest_no650

Hame Inasrt D asmi Page Layout Farmiulaz Dats Raviev WView

I_:IL Calibri {Body) » 12 v A N === ¥~ L. wrap Test = v E H .
5~ o
- B I Ur [ » Ox A — = = = 32 [ wierge & Center A E?:cr_afc e :
a Mumber
Al - fx  97TEI19R2E11637 I o BaaTIAATOR
A ] c ] £ G . 1 | o Currency
1 [ amezeazfisszeiieas 57maE2 1982611642 9,781 Eaf B11.637.00
I ATR-12 1582601183 STRE+1r 1983601191 iy Accounting
3 | S7EIE+12 1982586133 S TBIE+1Z 197SEEL41 $9,781,882,611,637.00
4 C== short Date
5 sxEpgarsys
5 o Long Date
I
: Time
8 R
10
1 g, Percentage
= M g7a1982E163ITO0.00%
1; Fractlon
13
14 2 grateszenesT
15 1o Scientific
16 BTBE412

17
18
13
D
1

aBc TExl
B.TRISRE+

2. gb to Custom, and choose 0.

Format Cells

Ly Alignment  Font  Border Fill  Protection

Category: Sample

General 9781982611637

Number

Currency .
Accounting Type:

Date 0

Time

Percentage General

Fraction o |
Scientific 0.00

Text # 40

Special # ##0.00

Custom #4400, (# #80)

###0_); [Red] (#,##0)

#,#440.00_); (#,#4#0.00)
#,##0.00_);[Red] (#,##0.00)
SH 0 ; (4, #40)

g3 #40 1-[Red] (S# ##0)

Type the number format code, using one of the existing codes as a starting point.

Cancel | LIS

12. Copy the first column (records may have more than one ISBN, but likely one ISBN is enough to
retrieve useful subject headings) to TextEdit (or any plain text editor) and save. This is to
ensure that all formatting is cleared.

13. Open Z39.50/SRU Client in MarcEdit.

14. Query OLUCWorldCat database. (Contact Content Coordinator for login information.)
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15. Check Batch Search, choose the newly created txt file with the ISBNs, and choose the name and

destination of the save file.
16. Select ISBN in the dropdown menu, and click the search icon, which will create a mrc file.

B. Prepare OCLC records

The preparation needed is included in a task file that you are about to download. It includes several
steps: move BISACSH from field 650 to a NNELS local field 946%a, delete all subject headings except
LCSH and FAST. You only need to run the task file described below.

1. Download the
Add LCSH and FAST task file

(right click the link and select "Save link as" to download).

2. Open MarcEdit.
3. Go to MarcEditor.
4. Go to Tools > Manage Tasks to open Task Manager.
5. Click the dropdown menu of Manage Existing Tasks
& o o L L ﬂ w
] Task Manager
Task List
MName Path Description
remove all non- fUsersfLilith/ This is to remove all subject

move_B50bisacshT /Users/Lilith/ Move BISACSH to 946%a
copy 650bisacshTo fUsers/Lilith/ Copy BISACSH to 946%a

Task Actions Manage Existing Task:

Import Selected Tasks n
Backup All Tasks

Delete Task Group
Export Selected Tasks

Import Selected Tasks

Mew Task Group

jE——

Select

Close
B 0

<< < of > = Pages: View AutoSave Files
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6. Choose Import Selected Tasks.
Navigate to the task file you downloaded earlier and import it.
Open the record set you generated in step A.16 in MarcEditor.
Go to Tools > Current Tasks and choose the task you just imported: Add LCSH and FAST
| | X N MarcEditor: 98auexcs. 3dsmarc9d53c08201fed374b51d4f1eafff0845.tmp
¥ File ~ Edit ~ Repaoris ¥ ‘S Tools - Plugins ~
| - .
| FLDR 02482nim a22003731a 4500 e e '

w oo

=001 rbdZ100119991 Clustering Tools

=003 MdPfRBL Cuttering Tools [

=005 20180521020010.0 Ganerate Call Numbers

=006 mctni Generate Control Numbers

=007 sSZ\TunnnmNLNeU

=007 crinnannnuuuua ROA HIE|pﬂr

=008 121004r2018201Bnyunnanialiizinieng\d Transliterate >

=020 WSa9TB00626T 1684 .

=028 WSaB7B00EZET 1684 Hegular Exp'esﬁlﬂn Store

=028 015aZ1001199915bRecomrded Books

=040 1SaMdPIRBLSbengScMdPIRBL Manage Tasks |

=100 1\SaKannedy, Robert F. Current Tasks > remove all non-LCSH he...

=245 108aAmerican values$blessons i learnad from my | move_650bisacshToB46

=250 “WSalnabridged. Generate MARC from URL copy.650bisacshTo946

=264 'a.SaNew_vom ‘SbHarper Audio ,Sa!Pﬂnm Frederik  Harvest OAl Records move_bisacsh to 946 bt

=300 WSa1 online rescurce (15 hr., 44 min.) Validate MARC Records ey e P
=506 iSaRestricted o use by people with & documentes __AddLCSHandFAST |

£39.50/SRU Client )

=538 \SaMode of access: World Wide Web.

=538 WSaRequires RBdigital Media Manager. Normalizs >

=538 “WSaSystem requiremants; 200 MB of free disk sps . rosoft .MET Framework 4 (xBE6 and
x64), Windows Media Player 10 QA Remove Blank Linas

=500 SaDownloadable audio fie. Remove Empty Fields/Subfields

=500 \SaTithe from tithe screen.

=511 (hSaMamrated by Stephen Graybill, Add/Delete Field

=530 “SaDownloadable applications available foracces  Build New Field th) and Android 2.1+ devices.

=520 ‘WSaWith rich detail, compelling honasty, and a sto Copy Field nedy in a tumultuous time in history
that garily echoes the issues of nuclear confrontation, re Edit Field Data Iy, This powerful book combines the
best aspects of memoir and political history. The thind cb ) . phew of JFK takes us on a joumney
through his lfle, including watershed moments in the hist  Edit Indicator Data lfe with intimate stories of RFK Jr.'s
own experiences, not just with historcal events and they  Edit Subfield Data her and father, his own struggles with
addiction, and the ways he eveniually made peace with Swap Field Data The result is & book that is remarkably

stiring and relevant, providing both insight and hope o7 mreeremss ara ume wisn ey ae neesew ke never before,
=650 \TSaBIOGRAPHY & AUTOBIOGRAPHY ! Political $Zbisacsh

=700 1'SaGraybill, Stephan S4nrt

=710 ASaHarperCaolling (Firm),

=045 WS&{OCalC)1035847009

<< = | 1 of 2 > =] 100 View AutoSave Files

10. You should get a Results screen with information on how many records have been processed
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o N Results
I

Loading Results...Your Task has completed in 0.0106831166666667 minutes. Information about

| changes from the task are as follows:
|

Copy Field Results:
273 modifications were made.

Edit Indicator Results: 546 modifications were made.
Dalete Field Results:
| Field: 650 \7

, Field Data: $2fast
| Results: 0 fields were deleted.

' Delete Field Results:
i Field: 650

| LX) Close E

11. Save the file in .mrk extension.

C. Prepare vendors' record set

1. Open the vendors' .mrk record set.
2. Repeat B.9 to B.11.

D. Merge OCLC and vendors' record sets

We will merge two fields (650 and 946) of the two record sets we prepared in B. and C. to get all
available LCSH and FAST subject headings.

1. If the option of "Merge MARC records" isn't present in Tools dropdown menu, begin typing
mer... in the search bar on the top right corner to call up the tool.
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o9 MarcEdit 3.1.70 by Terry Reese

g Tools ~ ﬂ Plugins. ~
I would like to:

Edit a MARC File

Harvest OAl Data

Merge MARC Data

Convert Characters Search YouTube for: mer

Work with Linked Data

med v
Merge MARC records together

Ask a question on the ListServ

X

MARC Tools Clustering
Tools

RDA
Helper

MarcEditor RDA Helper

Text Translator

=

Delimited MARCMNext

N

Q

239.50/ [@]
SRU Client

2. Make sure both the Source File (vendors' records) and Merge File (OCLC's records) are in mrk

format.
3. Name the Save File.

b

Choose "020%a" for Merge method (see F. if 20%$a isn't available in the vendors' record set).

5. Enter "650" and "946" in Field List and check Merge Unique Items, click Process.
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0 Merge Records
Source File: | /NNELS/2019-2020/subject_headings/test/te | Process
Merge File: | /NNELS/2019-2020/subject_headings/test/te |__J Close

Save File: /NNELS/2019-2020/subject_headings/test/te llj

Merge method: 020%a [~ |
Unicode Encoded

Select Fields:

Enter Field List: B50
845

Overlay Existing ltems
Merge Unigue Items

Confidence Value:

0.70

Merge has completed!. You can find your merged data at: /Users/Lilith/
Documents/My Documents/NNELS/2019-2020/subject_headings/test/test09/

E. Check missing subject headings

1. Go to Edit > Edit Shortcuts > Field Edits > Find Records Missing Field
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L N N MarcEditor: Blackstone.mrk

® File ~ . Edit *~ ,ﬁ Reports * « Tools b ﬂ Plugins ~ {
F"—Dﬂ 0 Ak Special Undo
=001 ZPdlcm =
=003 BLACP —
=005 20180121(__ Replace
=007 sditsngnne | Change Case »
=008 18110253  Jump to... > | Clear Smart Characters
=020 VSaSTE18 _ Math Functions > Clean ISBD Punctuation
i : : :
_E;E -:ﬁ;?:fgi nsert/Edit 006/008 > Correct {leubl/{reub) Mnemanic
=020 WSa19628 Convert Clipboard Content » Generate Paired ISEN-13 Value:
=028 305a07E1
=037 “SaZPede  Virtual Keyboard i 3% Find Records With Duplicate Ta
=037 VSaZEclomaunmmmnm ruumsmg Insert Record # as Comment

=040 WSaBLACPSbengSerdaScBLACP - .
060 VSaPEN1Z OMUSL0LS 30 i0eb Limit Number of FII&|.C|S
=082 0458813 65223 Replace HTML Entities
=100 1\Saloswanstein, Laurie Seauthor

=245 108aDeath of a rainmaker Sclaurie Loawensiain,

=250 WSallnabridged.

=264 15ajAshiand, Oregon] :SbBlacksions Publishing, Sc{2019]

=300 “Sab audio discs (10 172 hr.} :5bCD audio, digital ;Scd 34 in

=336 Saspoken wordSbapwSs2rdacontent

=337 VSasudioSbsS2rdamedia

=338 “Saaudio discSbedS2rdacarnar

=344 VSadigitalS2rdair

=344 SbopbcalS2rdarm

=34T USaaudio fileS2rdaft

=347 WSbCD audo

=490 1'5ad Dust Bowl Mystery SvBook 1

=500 VSaCompact discs.

=506 VSaRestricted 1o usa by peopla with a documernted print imparmeant.

=511 MSaRead by Emily Sutton-Smith

=520 "SaWhen a rainmaker is bludgeonad to death during a colossal dust storm, smallk-bown sharff Tomple Jennings shoulders yet another
burden in the hard times of the 1930s Dust Bowl

=650 WSaMurderSxinvestigation$vFiction

=650 WSaFarmersSvFiction

=650 0SaDeprassionsSvFiction.

=650 0SaDusi Bowl Era, 1931-19338wFiction

<<| < | |1 of 1 > == 100 View AutoSave Files

Enter 650.
If the result is 0, your record set is ready.
Otherwise, highlight the record and click Jump to.
Note the title and author (since we already did the OCLC search with ISBN, we will use title and
author to search for missing subject headings).
Open Z39.50/SRU Client in MarcEdit.
Query OLUCWorldCat, using title or author, or a combination of both.
8. Choose a record, click View Selected Record, locate the 650 field(s) that contain LCSH and/or
FAST subject headings, and copy the field(s) to the corresponding vendors' record
9. Save and repeat the steps with other items without subject headings.
10. When you are satisfied with all the records, go to File > Save As and add .xml as file extension.

vk wN

~No

Note: Although it is possible to do batch search in OCLC using title or author if a lot of records are
missing, due to the nature of title and author name variations, it is not easy to ensure that search
results are accurate. It is more reliable to work on each record individually.

F. When ISBN isn't in 020%a

Some record sets may have the ISBNs in a different field, like 028%a, but Merge MARC records only
works with 020%a. In such cases, the easiest is to use Copy Field instead of changing MARC settings.
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1. Open the file in Marc Editor. Go to Tools > Copy Field.
2. Put "028%a" in Source Field and "020%$a" in Destination Field, click Process.
3. Continue with D.4.
4. After the records are merged, delete field 020%$a from the vendors' records (remember to save
the file before following instructions).
1. go to Tools > Add/Delete Field
2. enter 020 in Field
3. click Delete Field
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